Podstawy funkcji Wyszukaj.pionowo

Łukasz Ruszkiewicz
25-11-2020

2 min

Funkcja WYSZUKAJ.PIONOWO jest bardzo praktyczną i popularną funkcją Excela.

Jeżeli jeszcze jej nie znasz, z pewnością warto się z nią zapoznać bliżej.

Spójrzmy na poniższy przykład.

Mamy tutaj listę produktów, z różnych kategorii. Zadanie polega na wpisaniu w kolumnę E odpowiedniej % prowizji, która jest przypisana do danej grupy, zgodnie z poniższą tabelą pomocniczą.

Produktów jest kilka tysięcy, więc ręczne wpisywanie oczywiście odpada.

Jednym z najprostszych rozwiązań jest zastosowanie funkcji WYSZUKAJ.PIONOWO.

Schemat tej funkcji wygląda następująco:

WYSZUKAJ.PIONOWO(szukana_wartość;tabela_tablica;nr_indeksu_kolumny;przeszukiwany_zakres)

Celem tej funkcji jest dopasowanie danych z jednej do drugiej tabeli.

W tym przypadku funkcja powinna wyglądać następująco:

=WYSZUKAJ.PIONOWO(B2;$H$2:$I$13;2;FAŁSZ) gdzie:

  • B2 to wartość, której szukamy w naszej tabeli pomocniczej
  • $H$2:$I$13 to adres tabeli pomocniczej, w której szukamy rodzaju produktu i pobieramy odpowiadające im wartości prowizji. Znaki $ oznaczają oczywiście zablokowanie tego zakresu, a więc używamy adresowania bezwzględnego.
  • 2 to numer kolumny, w której szukamy wyniku. Szukana wartość (czyli dla nas to kategorie produktowe) muszą znajdować się zawsze w kolumnie nr 1.
  • FAŁSZ oznacza, że szukamy dokładnego dopasowania. Drugą opcją jest PRAWDA, która daje przybliżone dopasowanie, ale tego rozwiązania nie rekomendowałbym w 99,99% przypadków.

Przeciągając formułę do końca, dzięki jednej formule mamy wyniki dla kilku tysięcy wierszy.